가전 디지털 특가

워드프레스와 PHP 버전

워드프레스 사이트 운영 시 PHP 버전은 어떤 것으로 선택해야 할까? 고민하시는 분들이 계시리라 생각됩니다. 워드프레스 권장 PHP 버전은 7.4 이상입니다.

  • PHP 버전 7.4 이상.
  • MySQL 버전 5.7 이상 – OR – MariaDB 버전 10.3 이상
  • HTTPS 지원

현재 PHP 8.1까지 릴리즈되었습니다.

지원되는 PHP 버전

PHP 7.4는 2022년 11월 28일에 보안 지원이 종료되므로 가급적 PHP 8.0 이상이 바람직합니다.

PHP 버전이 높을수록 사이트 속도에 유리하므로 먼저는 높은 PHP 버전을 적용하여 에러가 없는지 체크해보시기 바랍니다.

가령, PHP 8.1까지 적용이 가능하다면 먼저 PHP 8.1을 적용해보고, 문제가 발생하면 PHP 8.0으로 변경하여 테스트해볼 수 있습니다. PHP 8.0에서도 오류가 발생한다면 PHP 7.4로 변경하여 문제가 발생하지 않는지 확인할 수 있습니다.

또는, 문제가 특정 워드프레스 플러그인으로 인한 것이라면 해당 플러그인을 사용하지 않는 것도 고려해볼 수 있습니다.

PHP 8.1이 출시된 직후에는 최신 PHP 버전과 충돌을 일으키는 워드프레스 테마나 플러그인이 있었지만, 지금은 대부분의 인기 테마나 플러그인은 PHP 8.1에서 문제 없이 작동할 것입니다.

PHP 버전이 낮은 경우 웹호스팅 업체에 연락하여 PHP 버전 업그레이드에 대하여 상의해보시기 바랍니다.

※파트너스 활동의 일환으로 일정액의 수수료를 제공받을 수 있습니다.